• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Using LINKTOOLTIPINFO causes the tip to be embedded in the pseudo-links in preview. An example of this can be found at LinksBrokenByLinkTipInfoInPreview

I started digging into the code and found the issue. The <nop> tag in the tip was causing the replacement on the <a> tags to terminate prematurely. Removing the <nop> tags at the same time that double-quotes (") are removed appears to fix this.

I'm attaching the patch that fixed it, I tested it briefly and it doesn't appear to have any ill side-effects.


heh; you really, really don't want to go there (that nop has been the cause of soooo much trouble).

pseudo-links should not get tooltips. SVN 8488

CC

ItemTemplate
Summary LINKTOOLTIPINFO breaks links in preview
ReportedBy TWiki:Main.JasonHill
Codebase

SVN Range Tue, 24 Jan 2006 build 8482
AppliesTo Engine
Component

Priority Normal
CurrentState Closed
WaitingFor

Checkins 8487 8488
Topic attachments
I Attachment History Action Size Date Who Comment
Unknown file formatdiff bug1494.diff r1 manage 0.8 K 2006-01-24 - 08:37 JasonHill Suggested fix
Edit | Attach | Watch | Print version | History: r5 < r4 < r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r5 - 2006-01-24 - CrawfordCurrie
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback