• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item3471: Jump feature broken when a web does not have the WebTopicCreator topic

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Urgent Closed   patch 4.1.1

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

It seems the new feature for jump fails when you want to create a new topic.

It searches for WebTopicCreator within same web instead.

And when you upgrade an older TWiki you do not have this topic in every web.

The result is that TWiki suggests to create WebTopicCreator as topic.

This is very bad and our first bug item for 4.1.1

KJL

For some reason this ended in closed. Now it is open. And a critical bug which makes upgrading an extra pain

KJL

WORKAROUND FOR UPGRADERS.

Simply copy the WebTopicCreator.txt file from the TWiki web into each of your old Web directories. Then it all works fine.

KJL

I just noticed a related usability issue: If there are many topics in the web it takes ages until the create topic screen loads because of the number of parents to choose from. Probably good to offer two links in the "not found" screen:

  • one for quick create (with question mark link)
  • and one via the web topic creator topic

-- PTh

Are you actioning this Peter?

You did the WebTopicCreator change.

We need this fixed fast for 4.1.1

KJL

I suggest to go back to INCLUDE WebTopicCreator in WebTopicViewTemplate, but with a twist: a conditional INCLUDE. The "Create" link links to the same "DoesNotExist" topic but adds ?create=on to the url. Then the 'normal' WebTopicViewTemplate page is hidden and the included "create page" shown.

AC

Problem: it is not possible to INCLUDE a topic using IF if the topic contains quotes. Bummer.

Update: found a workaround.

AC

Merged into TWiki04x01

KJL

ItemTemplate
Summary Jump feature broken when a web does not have the WebTopicCreator topic
ReportedBy TWiki:Main.KennethLavrsen
Codebase 4.1.0, ~twiki4
SVN Range TWiki-4.1.0, Mon, 15 Jan 2007, build 12567
AppliesTo Engine
Component

Priority Urgent
CurrentState Closed
WaitingFor

Checkins 12648 12655
TargetRelease patch
ReleasedIn 4.1.1
Edit | Attach | Watch | Print version | History: r17 < r16 < r15 < r14 < r13 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r17 - 2007-02-05 - JasonHill
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback