• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item4248: Configure: Installed Plugins link is broken

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine Configure Low Confirmed   n/a  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

Open up the "Extensions" tab and click on the "Installed Plugins link". You end up in configure with a longer URL. Releat that a few times and you get something like this:

http://example.org/twiki/bin/configure/TWiki/view/TWiki/view/TWiki/InstalledPlugins

-- TWiki:Main/PeterThoeny - 15 Jun 2007

I don't. I get a link to the topic in my install. Are you sure you don't have a suspect rewriting rule?

-- CrawfordCurrie - 16 Jun 2007

I get this on develop.twiki.org as well. After two clicks: http://develop.twiki.org/~twiki4/cgi-bin/configure/Bugs/view/TWiki/view/TWiki/InstalledPlugins

-- TWiki:Main.PeterThoeny - 17 Jun 2007

Error came from Item187 - href of link is relative to base, but base is not defined. I have removed the link.

CC

Instead of removing the link, how about specifying a complete URL?

-- TWiki:Main.PeterThoeny - 17 Jun 2007

You can't specify a url on the site, because the url is in TWiki.spec and there is no way to find out the url of the site. There is no point in specifying a url on an external site, because it doesn't help you debug your installation.

I will leave this open for someone with more time than me to fix, but I'm dropping the priority from Normal to Low.

CC

Checkin 14242 is not relevant to this report.

CC

ItemTemplate
Summary Configure: Installed Plugins link is broken
ReportedBy TWiki:Main.PeterThoeny
Codebase 4.1.2, ~twiki4
SVN Range TWiki-4.1.2, Thu, 14 Jun 2007, build 14128
AppliesTo Engine
Component Configure
Priority Low
CurrentState Confirmed
WaitingFor

Checkins TWikirev:14184 TWikirev:14242
TargetRelease n/a
ReleasedIn

Edit | Attach | Watch | Print version | History: r9 < r8 < r7 < r6 < r5 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r9 - 2007-06-23 - TWikiUserMapping_CrawfordCurrie
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback