• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item5322: Plugins randomly disable on InstalledPlugins despite being enabled in configure

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Normal New   n/a  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

I have test run 2 seperate TWiki installations on two physically different linux servers... Both have manifested a very strange issue where they appear to pick a plugin at random and decide its disabled when viewing in InstalledPlugins .

Reinstalling the plugin does NOT fix the problem, and this has nothing to do with file ownership/permissions/etc. Going into configure, disabling the plugin, then re-enabling it fails to resolve the issue.

On one install, NatSkinPlugin does not work. On the other, SpreadSheetPlugin has decided to fail. No matter what I do, it won't work. I'm pretty sure this is something with the TWiki engine itself. I was ripping my hair out at first when NatSkinPlugin didn't work on my one install, but now that SpreadSheetPlugin is acting up in the identical fashion on another install, I'm pretty sure there's a very wierd bug here. Please email me if you have questions/suggestions for me to debug the source of this...

-- TWiki:Main/KevinFirko - 04 Feb 2008

Just to clarify since on second reading it doesn't appear completely clear: The plugins themselves do not work (ie: NatSkinPlugin and SpreadSheetPlugin are as if they are completely disabled), but are enabled in configure, and when they fail, they show themselves as "disabled" in InstalledPlugins... There really isn't any further error output listed on the InstalledPlugins topic.

-- TWiki:Main.KevinFirko - 05 Feb 2008

I've experienced a similar phenomenon with TWiki:Plugins.SpreadSheetPlugin disabling at will; this would be observable from the Installed Plugins page, but not the configuration dashboard. Coincidentally, it happens shortly after adding the TWiki:Plugins.PreferencesPlugin include within the System or User Web Preferences page(s).

Here's what resolves the issue for us:

First - Go to the system preferences page, where your settings for the system are kept, and confirm that the randomly disabled plugins are listed under Plugins Settings, next to DISABLEDPLUGINS, which is located right above ACTIVATEDPLUGINS.

Second - Turn off the DISABLEDPLUGINS setting by preceding it with the # sign (see below).

    *  #Set DISABLEDPLUGINS = SpreadSheetPlugin,EditTablePlugin
    * #Currently, %DISABLEDPLUGINS% is set to "%DISABLEDPLUGINS%" 

The main question for us, now, is what causes it to be written automatically there in the first place?!?

-- TWiki:Main.ShivaGoudarzi - 08 Feb 2008

ItemTemplate
Summary Plugins randomly disable on InstalledPlugins despite being enabled in configure
ReportedBy TWiki:Main.KevinFirko
Codebase 4.2.0
SVN Range TWiki-5.0.0, Wed, 23 Jan 2008, build 16283
AppliesTo Engine
Component

Priority Normal
CurrentState New
WaitingFor

Checkins

TargetRelease n/a
ReleasedIn

Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r3 - 2008-02-08 - ShivaGoudarzi
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback