• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item7829: Confirmation email after registration contains "0" as login name

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Normal Closed TWiki:Main.HaraldJoerg patch 6.1.0

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

This has been brought to my knowledge by an user of one of my recent installations, but until now I've been to lazy to follow up: We had a TemplateLogin in place, no login names ({Register}{AllowLoginName} = $FALSE;). and finally, {AntiSpam}{HideUserDetails} = 1;. After registering, he received a mail saying Login as "0".

I can easily reproduce this. The root cause is that the mail text is composed in a session which does not really belong to the user who is about to register. It can either be guest, or as well any authenticated (probably unprivileged) user who visited the registration page to register someone else. Therefore, it doesn't work to use %USERINFO{}% for variable substitution in the configuration mail: It doesn't expand anything unless an administrator performs the registration.

Also to be handled under this item: The same welcome message contains a note If you got this e-mail by mistake: Somebody ([_1]) registered at the [_2] site using your mail address [_3]. The inserts [_1] and [_3] are filled with data from the registration form. For [_1], this is just wrong when someone in an authenticated session (as in case 2 above) did the registration.

In both cases, either the registration code itself has to do the substitution outside of the usual TWiki variable expansion, or the expansion of %USERINFO{}% needs yet another special case to handle. I'm not sure which is uglier.

-- TWiki:Main/HaraldJoerg - 2017-11-30

ItemTemplate
Summary Confirmation email after registration contains "0" as login name
ReportedBy TWiki:Main.HaraldJoerg
Codebase ~twiki4, 6.0.2
SVN Range TWiki-6.0.2-trunk, Fri, 03 Nov 2017, build 30403
AppliesTo Engine
Component

Priority Normal
CurrentState Closed
WaitingFor TWiki:Main.HaraldJoerg
Checkins TWikirev:30423
TargetRelease patch
ReleasedIn 6.1.0
Edit | Attach | Watch | Print version | History: r5 < r4 < r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r5 - 2018-07-17 - PeterThoeny
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback