• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

if you state a dependency on a standard perl module in DEPENDENCIES, and the dependency is not satsfied on the target platform, then CPAN::Shell will automatically try to upgrade Perl.

This is because standard perl modules have perl in their prerequisites.

This can be avoided by checking to see if a module is a standard module before attempting to install it, and bottling out with a "I'm not touching that with a 16ft barge-pole" type of error.


Fixed by refusing to install core modules.

CC

ItemTemplate
Summary CPAN module installation can try to upgrade perl
ReportedBy TWiki:Main.CrawfordCurrie
Codebase ~twiki4
SVN Range TWiki-4.1-beta1, Mon, 24 Jul 2006, build 11161
AppliesTo Extension
Component BuildContrib
Priority Urgent
CurrentState Closed
WaitingFor

Checkins 11371 11372
TargetRelease n/a
Edit | Attach | Watch | Print version | History: r5 < r4 < r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r5 - 2006-08-25 - CrawfordCurrie
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback