• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

%TMPL:INCLUDE% not working for SubWebs.

I changed REGEX in lib/TWiki/Templates.pm line 322:

This:

/^(\w+)\.(\w+)$/

For:

/^((?:\w+\.?)+)\.(\w+)$/


Hmmm. Hadn't anticipated that templates might be stored in hierarchical subwebs. I can't think of any reason why your fix isn't right, so I guess it can go into subversion.

CC


TWiki:Main.NelsonFerraz did an better regexp for this patch:
/^(\w[\w\.]*)\.(\w+)$/

AAH


There has been a huge change made by Thomas W in the way and paths we use to load templates. Maybe this change makes this bug item either not an issue or fixed??

Setting to waiting for feedback and editing topic.

KJL

No feedback for a long time. Discarding

KJL

ItemTemplate
Summary %TMPL:INCLUDE{"Web.Subweb.Topic"}% not working (FB from TW, AC and MD needed)
ReportedBy TWiki:Main.JoenioCosta
Codebase 4.0.0, 4.0.4
SVN Range TWiki-4.1-beta1, Wed, 30 Aug 2006, build 11391
AppliesTo Engine
Component

Priority Low
CurrentState No Action Required
WaitingFor

Checkins

TargetRelease n/a
Edit | Attach | Watch | Print version | History: r6 < r5 < r4 < r3 < r2 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r6 - 2007-01-02 - KennethLavrsen
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback