• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.
Hi all,

After that I've updated to TWiki-4.1.0 I receive this kind of error every time I access a web. I don't know if it's related on a custom setting or if it's a bug.

Could you please help me to find out the problem?

Thanks in advance Regards Antenore.


We need much more background info.

  • What kind of authentication: Apache or Template
  • What is the EXACT error message?
  • Can you look at configure and save the html and attach it?
  • We need your Apache configuration
  • Errors in your apache error_log

KJL


Hi,

Thanks a lot for the quickly feedback.

* We use Apache authentication (with mysql back-end) * The eror that I've reported is in the apache error log:

[Fri Jan 19 19:05:08 2007] [error] [client xxx.xxx.xxx.xxx] File does not exist: /content/twiki/pub/SomeWeb/WebPreferences

* I cannot attach the full configure output because it contains too many sensible data (enterprise environment), I've attached a LocalSite.cfg and environemnts.cfg files without such informations.

* For Apache configuration is it enough this?

# Mod_perl preloading
Perlrequire /content/twiki/tools/mod_perl_startup.pl
PerlSwitches -T

# The ScriptAlias defines the bin directory as a directory where CGI
# scripts are allowed.
ScriptAlias /twiki/bin "/content/twiki/bin"

# The Alias defines a url that points to the root of the twiki installation.
Alias /twiki "/content/twiki"

<Location "/twiki/bin/view/TWiki/TWikiRegistration">
    require valid-user
</Location>

<Directory "/content/twiki/bin">
        SetHandler perl-script
        PerlHandler ModPerl::Registry
    PerlOptions +ParseHeaders
    Options +ExecCGI

    AllowOverride All
    Order Allow,Deny
    Allow from all
    Deny from env=blockAccess

    SetHandler cgi-script

    # File to return on access control error (e.g. wrong password)
        ErrorDocument 401 /error/upgrade_user.pl

        Include "conf/mysql.conf"

    <FilesMatch "[^/]*\.html$">
        SetHandler blabla
        Allow from all
    </FilesMatch>

# Limit access to configure to specific IP addresses and or users.
<FilesMatch "^(configure)$">
    SetHandler cgi-script
    require valid-user

</FilesMatch>

# Enable mod_perl for the bin scripts listed

<FilesMatch "viewauth|edit|preview|save|attach|upload|rename|manage|installpasswd|register">
        require valid-user
</FilesMatch>

</Directory>

<Directory "/content/twiki/pub">
    Options FollowSymLinks +Includes
    AllowOverride None
    Order Allow,Deny
    Allow from all
    Deny from env=blockAccess

    # Disable execusion of PHP scripts
    php_admin_flag engine off

</Directory>

Regards Antenore.


You are using an old TWiki config. I can see this from the fact that you have +Includes in pub. This is a security issue!

I encourage you to visit the TWiki:Codev.ApacheConfigGenerator and make a fresh new config file and then tailor what you need. It can also generate the mod_perl version.

I think I now understand what the problem you have is. Your installation works but you get these entries in the error log.

When you upgrade TWiki from Cairo to TWiki4.X you see this non-fatal error. It comes from some template that tries to make the browser fetch the favicon.ico file which is attached to the WebPreferences topic in each web. The easiest workaround is to attach this file to each web.

Please confirm that this cures things.

To the development community: Why does the template look at the WebPreferences topic in each web instead of the TWiki web?

KJL


Thanks a lot! It works perfectly now. I've updated the Apache configuration and manually add the favicon.

I leave the status to "New" for further discussions if needed.

B.R. Antenore.


Please don't leave bug reports in New state, and please use the Support web on TWiki.org for support requests. Ken, if you want to fullow up on that question, you might have more feedback on the mailing list.

Moving to No Action.

CC

ItemTemplate
Summary File does not exist: /content/twiki/pub/AnyWeb/WebPreferences
ReportedBy TWiki:Main.AntenoreGatta
Codebase 4.1.0
SVN Range TWiki-4.1.0, Mon, 15 Jan 2007, build 12567
AppliesTo Engine
Component

Priority Normal
CurrentState No Action Required
WaitingFor

Checkins

TargetRelease n/a
ReleasedIn

Topic attachments
I Attachment History Action Size Date Who Comment
Unknown file formatcfg LocalSite.cfg r1 manage 8.4 K 2007-01-22 - 15:31 UnknownUser LocalSite.cfg
Unknown file formatcfg environments.cfg r1 manage 3.5 K 2007-01-22 - 15:31 UnknownUser environments.cfg
Edit | Attach | Watch | Print version | History: r7 < r6 < r5 < r4 < r3 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r7 - 2007-02-02 - CrawfordCurrie
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback