• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item3763: Base meta tag contains :port twice

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Normal No Action Required   n/a  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

Installed ver 4.2.1 fresh yesterday.
Apache/2.0.59 on port 2080
Linux 2.6.9 (centOS)

The base tag in the header of each page is e.g,

   <base href="http://domain.tld:2080:2080/twiki/bin/view/TWiki/WebHome"></base>

Originally after installation DefaultUrlHost? was automatically populated with the double :port in the url which i corrected. My guess is whatever is creating the base tag (and activation links in emails) is using the same method used to guess the DefaultUrlHost initally.

FireFox seems to be able to work despite this, however internet explorer displays page content with no images, scripting, css or working links.

There is also a question here http://twiki.org/cgi-bin/view/Support/PageProblemWithIE6or7

-- TWiki:Main/JacobDorman - 14 Mar 2007

So this only affects initial installation? Nothing after configure "guesses" the DefaultUrlHost; it is set in LocalSite.cfg. And configure just uses the value of $ENV{HTP_HOST}. Please run configure and check the value of HTTP_HOST in the environment valriables section, and also please grep LocalSite.cfg for 2080 and report what it says here, thanks.

CC

I just discovered that in CGI.pm version 3.28 a bug "in which port number appears twice" has been fixed. I don't know whether this is what bites here, but TWiki is using CGI.pm for URL manipulation. Please run perl -mCGI -e 'print $CGI::VERSION'. If the version is 3.27 or so, an upgrade of CGI.pm might help.

-- TWiki:Main.HaraldJoerg - 13 Apr 2007

Jacob, any feedback? If we don't hear from you before 13 May we will discard this, on the assumption that Harald's analysis applies.

-- TWiki:Main.CrawfordCurrie - 02 May 2007

closing.

the problem was almost certainly the buggy release of CPAN:CGI

-- WillNorris - 13 May 2007

ItemTemplate
Summary Base meta tag contains :port twice
ReportedBy TWiki:Main.JacobDorman
Codebase 4.1.2
SVN Range TWiki-4.1.2, Sat, 03 Mar 2007, build 13043
AppliesTo Engine
Component

Priority Normal
CurrentState No Action Required
WaitingFor

Checkins

TargetRelease n/a
ReleasedIn

Edit | Attach | Watch | Print version | History: r5 < r4 < r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r5 - 2007-05-13 - TWikiUserMapping_WillNorris
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback