• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item4016: WYSIWYG editer breaks the view of topics on IE7.

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Extension KupuContrib Normal No Action Required   n/a  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

This problem occurs if certain Plugins are enabled.

After editing a topic with WYSIWYG on a IE7 browser I am unable to view the page. I see the Twiki header but the rest of the page does not load. The topic has been updated though and the following line has been inserted at the start of the file.

 
 <LINK href="/twiki/pub/TWiki/KupuContrib/kuputwiki.css" 
 type=text/css rel=stylesheet>
 <SCRIPT language=javascript 
 src="twiki/pub/TWiki/TimeTablePlugin/timetabletooltips.js" 
 type=text/javascript> 
 
 

I have the latest version of the plugin on TWiki 4.1.2

Daniel Rohde was able to supply a workaround but suggest that I post the problem here. He says

 
I cannot fix this problem because I cannot reproduce it. It's not the 
normal behavior of the Kupu WYSIWYG editor to put a <LINK> tag into the 
topic text. You should report this problem to the Kupu developer page: 
http://twiki.org/cgi-bin/view/Plugins/KupuContribDev

The TimeTablePlugin does the same '</head>' replacement like the 
ChecklistPlugin and the RackPlannerPlugin and therefore we need a 
solution. But the problem with the <LINK> tag occurs without this 
replacment ... I think, it's a Kupu bug.

-- TWiki:Main/PeterJones - 04 May 2007

It's probably not a Kupu bug, it's more likely to be an order issue in the core plugin handling. Ihe WysiwygPlugin tries to protect the topic content from the rest of the plugins when it is serving the text content, but it looks like it isn't always successful.

I think Daniel is right, and this is nothing to do with Kupu. I think one of your other plugins is mangling the HEAD tag. No action.

-- TWiki:Main.CrawfordCurrie - 04 May 2007

ItemTemplate
Summary WYSIWYG editer breaks the view of topics on IE7.
ReportedBy TWiki:Main.PeterJones
Codebase 4.1.2
SVN Range TWiki-4.1.2, Thu, 03 May 2007, build 13616
AppliesTo Extension
Component KupuContrib
Priority Normal
CurrentState No Action Required
WaitingFor

Checkins

TargetRelease n/a
ReleasedIn

Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r3 - 2007-06-14 - TWikiUserMapping_CrawfordCurrie
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback