• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item4162: Formatted searches fails when several on same page

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Urgent Closed   minor  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

A new tricky bug

On my Merlin test machine I get this error

Could not perform search. Error was: /bin/fgrep -i -l -H -- %TOKEN|U% %FILES|F% returned an error 

on the FormattedSearch page.

On another machine with a newer distro I do not get the error.

On the merlin machine a 4.1.2 does not fail either. Something in the new search code returns error in certain circumstances.

I have no errors in the apache error_log

You can see the error here

http://merlin.lavrsen.dk/twiki/bin/view/TWiki/FormattedSearch

If you take one of the individual searches and copy to another topic it works. So it seems related to multiple searches on same page.

The server auto updates from SVN once an hour so if it gets fixed you can see it max an hour later on the URL above.

-- TWiki:Main/KennethLavrsen - 30 May 2007

Not sure how to debug this one. On my svn checkout, multiple searches works normally.

-- PTh

yes it is tricky - as I said one of my machines shows the problem and one does not. Anyone have a hint for me how to dig out more debug info to solve this one?

If I see it others will too.

KJL

look at the versions of grep used on both machines. Are they the same? Enable tracing in the sandbox module, and look at the fgrep command being executed. paste it onto the command line on both machines. What is the error?

CC

Quick reply on the grep version. Both are 2.5.1.

Will start tracing as suggested.

KJL

I know why it fails now. I will check in the fixes. You will be surprised what the error is.

And it is not the search code that is the problem. Thanks for the hint with the trace in Sandbox. I was not aware of that little feature.

KJL

This is not a real bug actually.

A number of less experienced plugin authors have goofed their MANIFEST files and this creates broken links when you run pseudo-install

My merlin test server uses -link all because I often test many plugins. But my other server uses -link default

It is good that pseudo-install creates broken links because that catches these bad MANIFEST files.

But we have to fix the links when we see them because grep returns an error when it tries to follow a link pointing to a non existing topic.

No code to be fixed. But I use this to check in the MANIFEST changes.

That was a funny one.

-- TWiki:Main.KennethLavrsen - 30 May 2007

ItemTemplate
Summary Formatted searches fails when several on same page
ReportedBy TWiki:Main.KennethLavrsen
Codebase ~twiki4
SVN Range TWiki-4.1.2, Fri, 18 May 2007, build 13796
AppliesTo Engine
Component

Priority Urgent
CurrentState Closed
WaitingFor

Checkins TWikirev:13988
TargetRelease minor
ReleasedIn

Edit | Attach | Watch | Print version | History: r5 < r4 < r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r5 - 2007-05-30 - TWikiUserMapping_KennethLavrsen
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback