• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item4976: Admin (sudo=sudo) login sequence fails when managing webs

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Urgent Closed   minor 4.2.0

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

  1. Template login
  2. Don't log in
  3. Visit ManagingWebs
  4. Choose to create a new web
  5. At the login screen, select the administrator login option
  6. Log in as the administrator

Kablowie!

Use of uninitialized value in string eq at /home/twiki/420/lib/TWiki/UI/Manage.pm line 54.
 at /home/twiki/420/lib/TWiki/UI.pm line 84
   TWiki::UI::__ANON__('Use of uninitialized value in string eq at /home/twiki/420/li...') called at /home/twiki/420/lib/TWiki/UI/Manage.pm line 54
   TWiki::UI::Manage::manage('TWiki=HASH(0x82daa8c)') called at /home/twiki/420/lib/TWiki/UI.pm line 159
   TWiki::UI::__ANON__() called at /usr/local/share/perl/5.8.8/Error.pm line 426
   eval {...} called at /usr/local/share/perl/5.8.8/Error.pm line 418
   Error::subs::try('CODE(0x814ed30)', 'HASH(0x897e160)') called at /home/twiki/420/lib/TWiki/UI.pm line 197
   TWiki::UI::run('CODE(0x82dab88)') called at /home/twiki/420/bin/manage line 33.
 

Looks like the login parameters are not being passed on - which is OK (ish) though the manage script should not suicide so inelegantly.

-- TWiki:Main/CrawfordCurrie - 15 Nov 2007

the parameter thats missing from line 54 is the action urlparam. its not the login sequence itself that is failing, its because the non-login parameters are lost. I wonder if this is sudo, or just all login? -- SvenDowideit - 16 Nov 2007

I suspect it's because the link from the login page to the administrator login is just a simple link, rather than a form submit, so the parameters aren't getting passed on.

CC

Changed the log in as administartor link to a submit, which when combined with the sudo parameter causes a sudo login with all the right passthrough params.

-- TWiki:Main.CrawfordCurrie - 16 Nov 2007

The interface for the button is not clear, see Item4993.

-- TWiki:Main.ArthurClemens - 19 Nov 2007

ItemTemplate
Summary Admin (sudo=sudo) login sequence fails when managing webs
ReportedBy TWiki:Main.CrawfordCurrie
Codebase 4.2.0, ~twiki4
SVN Range TWiki-4.3.0, Thu, 15 Nov 2007, build 15592
AppliesTo Engine
Component

Priority Urgent
CurrentState Closed
WaitingFor

Checkins TWikirev:15621 TWikirev:15622
TargetRelease minor
ReleasedIn 4.2.0
Edit | Attach | Watch | Print version | History: r12 < r11 < r10 < r9 < r8 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r12 - 2007-11-19 - ArthurClemens
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback